Canvis Recents - Cercar:

HomePage

Serveis

Nodes

Propostes

Documentaciķ?

Donacions

Com conectar-me

Instalˇlacions

Telefonia

Proxmox?

Wiki

edit SideBar

PropostaQoS

Proposta de QoS 1 per routers Mikrotik (versiķ estable)

Proposta de QoS 2 - estable des de 2010 (versiķ actual a Matarķ)

Objectius:

-Prioritzar el trāfic segons el servei que s'utilitzi (amb QDISC)

-Garantir un mateix ample de banda per usuari (amb PCQ)

Prioritzaciķ de trāfic:

1-Interactiu (enrutament dināmic: OSPF, BGP, EGP i DNS)

2-VOIP (telefonia sobre IP:SIP I IAX2)

3-Manteniment (ssh, telnet i winbox)

4-VPN (PPTP I OPEN VPN)

5-Proxy (bona part del trāfic actual)

6-Bulk (la resta del trāfic)

7-P2P (ftp, p2p i sopa de pedres)

Política de marcatge de paquets

PCQ --> marca els paquets a Forward i posa a la cua a Global-out

QDISC --> marca els paquets a Prerouting i posa en cua a Global-in

Fonts

http://guifi.net/node/17370

http://tamax.com.ar/blog/?p=938

http://mum.mikrotik.com/presentations/CZ09/QoS_Megis.pdf

http://wiki.mikrotik.com/wiki/Bandwidth_Managment_and_Queues

http://www.mikrotik.com/testdocs/ros/2.9/root/queue.php

Configuraciķ proposada:

---MARCATGE DE PAQUETS----------------------------------------------

/ip firewall mangle

add action=mark-packet chain=prerouting comment=ospf disabled=no new-packet-mark=interactive passthrough=no protocol=ospf

add action=mark-packet chain=prerouting comment=bgp disabled=no new-packet-mark=interactive passthrough=no protocol=egp

add action=mark-packet chain=prerouting comment=ping disabled=no new-packet-mark=interactive passthrough=no protocol=icmp

add action=mark-packet chain=prerouting comment=DNS disabled=no new-packet-mark=interactive passthrough=no protocol=udp src-port=53

add action=mark-packet chain=prerouting comment=DNS disabled=no dst-port=53 new-packet-mark=interactive passthrough=no protocol=udp

add action=mark-packet chain=prerouting comment=DNS disabled=no new-packet-mark=interactive passthrough=no protocol=tcp src-port=53

add action=mark-packet chain=prerouting comment=DNS disabled=no dst-port=53 new-packet-mark=interactive passthrough=no protocol=tcp

add action=mark-packet chain=prerouting comment="SIP and RTP" disabled=no dscp=46 new-packet-mark=voip passthrough=no

add action=mark-packet chain=prerouting comment="SIP and RTP" connection-type=sip disabled=no new-packet-mark=voip passthrough=no

add action=mark-packet chain=prerouting comment="" disabled=no dscp=26 new-packet-mark=voip passthrough=no

add action=mark-packet chain=prerouting comment="IAX2 entrada" disabled=no dst-port=4569 new-packet-mark=voip passthrough=no protocol=udp

add action=mark-packet chain=prerouting comment="IAX2 sortida" disabled=no new-packet-mark=voip passthrough=no protocol=udp src-port=4569

add action=mark-packet chain=prerouting comment="SSH entrada" disabled=no dst-port=22 new-packet-mark=manteniment passthrough=no protocol=tcp

add action=mark-packet chain=prerouting comment="SSH sortida" disabled=no new-packet-mark=manteniment passthrough=no protocol=tcp src-port=22

add action=mark-packet chain=prerouting comment="telnet entrada" disabled=no dst-port=23 new-packet-mark=manteniment passthrough=no protocol=tcp

add action=mark-packet chain=prerouting comment="telnet sortida" disabled=no new-packet-mark=manteniment passthrough=no protocol=tcp src-port=23

add action=mark-packet chain=prerouting comment="winbox entrada" disabled=no dst-port=8291 new-packet-mark=manteniment passthrough=no protocol=tcp

add action=mark-packet chain=prerouting comment="winbox sortida" disabled=no new-packet-mark=manteniment passthrough=no protocol=tcp src-port=8291

add action=mark-packet chain=prerouting comment="Proxy entrada" disabled=no dst-port=3128 new-packet-mark=proxy passthrough=no protocol=tcp

add action=mark-packet chain=prerouting comment="Proxy sortida" disabled=no new-packet-mark=proxy passthrough=no protocol=tcp src-port=3128

add action=mark-packet chain=prerouting comment="PPTP entrada" disabled=no dst-port=1723 new-packet-mark=vpn passthrough=no protocol=udp

add action=mark-packet chain=prerouting comment="PPTP sortida" disabled=no new-packet-mark=vpn passthrough=no protocol=udp src-port=1723

add action=mark-packet chain=prerouting comment="PPTP entrada" disabled=no dst-port=1723 new-packet-mark=vpn passthrough=no protocol=tcp

add action=mark-packet chain=prerouting comment="PPTP sortida" disabled=no new-packet-mark=vpn passthrough=no protocol=tcp src-port=1723

add action=mark-packet chain=prerouting comment="OPENVPN entrada" disabled=no dst-port=1194 new-packet-mark=vpn passthrough=no protocol=udp

add action=mark-packet chain=prerouting comment="OPENVPN sortida" disabled=no new-packet-mark=vpn passthrough=no protocol=udp src-port=1194

add action=mark-packet chain=prerouting comment="OPENVPN entrada" disabled=no dst-port=1194 new-packet-mark=vpn passthrough=no protocol=tcp

add action=mark-packet chain=prerouting comment="OPENVPN sortida" disabled=no new-packet-mark=vpn passthrough=no protocol=tcp src-port=1194

add action=mark-packet chain=prerouting comment=vpn disabled=no new-packet-mark=vpn passthrough=no protocol=gre

add action=mark-packet chain=prerouting comment="BGP TCP entrada" disabled=no dst-port=179 new-packet-mark=interactive passthrough=no protocol=tcp

add action=mark-packet chain=prerouting comment="BGP TCP sortida" disabled=no new-packet-mark=interactive passthrough=no protocol=tcp src-port=179

add action=mark-packet chain=prerouting comment=FTP connection-type=ftp disabled=no new-packet-mark=p2p passthrough=no

add action=mark-packet chain=prerouting comment=P2P disabled=no new-packet-mark=p2p p2p=all-p2p passthrough=no

add action=mark-packet chain=prerouting comment=Sopa disabled=no dst-address= 10.139.66.34 dst-port=80 new-packet-mark=p2p passthrough=no protocol=tcp

add action=mark-packet chain=prerouting comment=Sopa disabled=no dst-address= 10.139.56.134 dst-port=80 new-packet-mark=p2p passthrough=no protocol=tcp

add action=mark-packet chain=prerouting comment=BULK disabled=no new-packet-mark=bulk packet-mark=!interactive passthrough=no

add action=mark-packet chain=forward comment="" disabled=no new-packet-mark= pcq passthrough=no

---CUES--------------------------------------------------------------------

/queue tree

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=qdisc parent=global-in priority=1

/queue type

set default kind=pfifo name=default pfifo-limit=50

set ethernet-default kind=pfifo name=ethernet-default pfifo-limit=50

set wireless-default kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=5

set synchronous-default kind=red name=synchronous-default red-avg-packet=1000 red-burst=20 red-limit=60 red-max-threshold=50 red-min-threshold=10

set hotspot-default kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb= 5

add kind=pcq name=pcq_up pcq-classifier=src-address pcq-limit=50 pcq-rate= 8000000 pcq-total-limit=2000

add kind=pcq name=pcq_down pcq-classifier=dst-address pcq-limit=50 pcq-rate= 8000000 pcq-total-limit=2000

set default-small kind=pfifo name=default-small pfifo-limit=10

/queue tree

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=500k max-limit=4M name=interactive packet-mark=interactive parent=qdisc priority=1 queue=wireless-default

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=500k max-limit=4M name=voip packet-mark=voip parent=qdisc priority=3 queue= wireless-default

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=500k max-limit=4M name=manteniment packet-mark=manteniment parent=qdisc priority=4 queue=wireless-default

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M max-limit=4M name=vpn packet-mark=vpn parent=qdisc priority=5 queue= wireless-default

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2M max-limit=4M name=proxy packet-mark=proxy parent=qdisc priority=6 queue= wireless-default

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=8M name=bulk packet-mark=bulk parent=qdisc priority=7 queue= wireless-default

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=8M name=p2p packet-mark=p2p parent=qdisc priority=8 queue= wireless-default

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="pcq down" packet-mark=pcq parent=global-out priority=1 queue=pcq_down

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="pcq up" packet-mark=pcq parent=global-out priority=1 queue=pcq_up

/queue interface

set ether1 queue=ethernet-default

set ether2 queue=ethernet-default

set ether3 queue=ethernet-default

set wlan1 queue=wireless-default

set wlan2 queue=wireless-default

set wlan3 queue=wireless-default

set wLan/Lan queue=default

Edita - Histōria - Imprimir - Canvis Recents - Cercar
Darrera modificaciķ de la pāgina el 27 de November del 2011 a les 11h29